Third-party software requirements

xfODBC is supported for use only with versions of third-party software that are currently supported by the manufacturer. For information on requirements for stand-alone and client/server configurations, see xfODBC requirements and installation.

Software

Requirements

ADO.NETa

.NET Framework 4.0 or higher

Visual Studio 2013 with Update 4

Visual Studio 2015 with Update 2

Visual Studio 2017 version 15.4

Microsoft Office

Office 2010 with Service Pack 3 or higher

SQL Servera

SQL Server 2012 and higher

a. We do not recommend installing xfODBC to run in a shared configuration when you are running Visual Studio or the client machine for xfODBC development. However, if you do have this configuration, you must change your .NET security permissions on the client machine to permit access to the xfODBCSpecialization assembly for your Visual Studio version (xfODBCSpecialization12.dll for Visual Studio 2013, xfODBCSpecialization14.dll for Visual Studio 2015, or xfODBCSpecialization15.dll for Visual Studio 2017). This is assembly is located in the SynergyDE\connect directory on the shared machine. It enables xfODBC to work with Visual Studio wizards.