U_MINVERSION

Check for minimum Synergy/DE product versions

WTSupported in traditional Synergy on Windows
WNSupported in Synergy .NET on Windows
USupported on UNIX
VSupported on OpenVMS
xcall U_MINVERSION([minimum_toolkit][, minimum_runtime])

Arguments

minimum_toolkit

(optional) The minimum UI Toolkit version required. (a)

minimum_runtime

(optional) The minimum Synergy Runtime version required. (a)

Discussion

U_MINVERSION checks the version of Toolkit against minimum_toolkit and the version of the Synergy Runtime against minimum_runtime. If the version of Toolkit or the Synergy Runtime is lower than a minimum passed to U_MINVERSION, Toolkit generates a fatal error.

Use the following syntax for minimum_toolkit and minimum_runtime (where v is the version number, r is the major revision number, and m is the minor revision number):

v[.r][.m]

You can use an uppercase letter for a two‑byte version number. For example, you can use A for 10, as in A.1.1 for 10.1.1. But note that if you do use an uppercase letter, it must be the first character of v, r, or m. In this case, the second character is ignored—for example, 1A.2.3 is interpreted as 1.2.3, and A1.2.3 is interpreted as 10.2.3. Additionally, note the following:

Examples

The following generates a fatal Toolkit error if the Synergy Runtime version is lower than 9.5.3:

xcall u_minversion(,"9.5.3")

The following examples check to make sure that the version of both UI Toolkit and the Synergy Runtime are at least 10.1.1:

xcall u_minversion("10.1.1", "10.1.1")
xcall u_minversion("A.1.1", "A.1.1")