System requirements

xfNetLink .NET is supported only on Windows platforms; however, you can create an assembly from Synergy routines that reside on UNIX and OpenVMS.

To build a distributed system with xfNetLink .NET and xfServerPlus, you’ll need the .NET Framework version 4 or higher. The .NET Framework is installed with Visual Studio, or you can download it from the Microsoft website. If you do the latter, be sure to get the full version, which is intended for developers.

We recommend that you also install Microsoft Visual Studio version 2012 or higher, but Visual Studio is not required to build a Synergy assembly. If you do not have Visual Studio, you will need to install Visual Studio Express 2012 or 2013, along with the Windows SDK 7.1. These applications will provide the tools necessary to build a Synergy assembly. When you build the assembly, use vsvars32.bat to set up the .NET environment.

You’ll also need to be familiar with some .NET Framework concepts. Here are some of the topics you may need to research: